Updating Help menus

Hi @Twistappel
menus.odt (150,0,KB)

Please find attached a small document on the task to perform. For the moment, I need a list of issues. The Help application is a bit complex so I can spare the bits&bytes for you, unless you want to challenge yourself in coding and XML technicalities, but on another moment.

See if you are comfortable to address the issue and don’t hesitate to ask here for help or telegram.

I use to give credit to whoever is part of the solution. In LibreOffice, that translates to a patch in the code (patch to the Help). Patches have authors and reviewers. I propose to write myself the XML patch and give you authorship for your resumé. Let me know if you are OK this way. See how a patch looks like:


As you see, it is full of XML bla bla bla.

I also suggest you start with the Draw application.


Hi Olivier,

I’m trying to make a start on the review of the Help menus, but don’t think the Help function is working correctly for me. No matter which menu item I highlight, I can only ever open the “Welcome” page in Offline Help:

I’ve tried several menu options in different LO applications.

Do you know if this is a known issue? My PC is running on Pop!_OS, and directly downloaded Debian files for LIbreOffice 7.6.3 and Offline Help.

Assuming I can get the Help application to run properly for me and complete the review, I would like to try coding the Patch myself, if that would be OK. I’d like to expand my coding skills, and I learn faster if I have a specific project. It may just take me a little while to figure out what I’m doing.




Hi Dione
Yeah… that is part of the problem!. Can you check with the Help button on a simple dialog box to see if the Help is opening on the right page (e.g. Format - Paragraph - Help)?

Also, check if you have removed the LibreOffice offered by your Pop_OS distro. It’s better to work on the LibreOffice from the LibreOffice website.


Hi Olivier,

Yes, I seem to be able to open the right Help page from a dialogue box. It’s just pressing F1 that is the problem. If that’s the problem I’m meant to be documenting it’s fine. I just didn’t expect to get the same result from every menu item.

I think I’ve successfully removed the version of LibreOffice offered by Pop_OS. My skills with Linux are admittedly fairly basic, but I uninstalled through the graphical ui and ran -

sudo apt-get remove --purge "libreoffice*"
sudo apt-get clean
sudo apt-get autoremove

before I installed the debian files. Running apt list --installed libreoffice* shows the following:

libreoffice7.6-base/now amd64 [installed,local]
libreoffice7.6-calc/now amd64 [installed,local]
libreoffice7.6-debian-menus/now 7.6.3-2 all [installed,local]
libreoffice7.6-dict-en/now amd64 [installed,local]
libreoffice7.6-dict-es/now amd64 [installed,local]
libreoffice7.6-dict-fr/now amd64 [installed,local]
libreoffice7.6-draw/now amd64 [installed,local]
libreoffice7.6-en-us/now amd64 [installed,local]
libreoffice7.6-impress/now amd64 [installed,local]
libreoffice7.6-math/now amd64 [installed,local]
libreoffice7.6-ure/now amd64 [installed,local]
libreoffice7.6-writer/now amd64 [installed,local]
libreoffice7.6/now amd64 [installed,local]



Hi Dione

Please open a terminal on Pop_OS and insert the following command:

SAL_USE_VCLPLUGIN=gen /opt/LibreOffice7.6/program/soffice

It will open LO and test the F1 key on the menu entries.

Hi Olivier,

I tried using the above command to open LO. I can now open the correct help page using the Standard UI and Context menu, although it still doesn’t work using the ribbon in the Tabbed UI.



All right.
Just enable the standard menu together with the ribbon.

Hi Olivier,

Thanks very much for all your help.

One more question - Could I just check that this is the type of information that you are looking for:


Great job! On the track.
some remarks

  • If the help page is opening correctly, there is no need to report.

  • In the URL, the useful part to pick is “/text/s.../nn/file.html”. That is enough to get the source file to work on.

  • If you get a page that says “Missing HelpID:(...)”, that is what we are after. Please report the HelpID.

  • We only need the name of the icon of the command. The icons are in this link : The Document Foundation Nextcloud . Unzip in a work folder and do a visual inspection to get the right one. Choose the icon name prefixed with “lc_”.

Do not hesitate to ask for more help. We can progress in an steady way. Later we will approach the XML coding.

Thanks very much. I’ll make the adjustments and go through the rest of the menus.


Hi Olivier,

I’ve got a bit of an odd question. What is the proper name for the section at the top, left-hand corner of the Tabbed UI that persists across tabs (see attached screenshot)? I’m trying to explain where to find the “Undo” and “Redo” functions on the Tabbed UI.

I looked in the User Guide, but I couldn’t find an answer.

Good question!!! I don’t know…

I just left as it is part of the tabbed user interface:



Thanks. Glad it’s not just me.

There doesn’t appear to be a corresponding button on any of the tabs like there is for Open, so I might just leave it blank. The instruction under “Toolbars” probably adequately describes it.