Converting a General cell to date creates an invisible '

Trying to convert a .csv bank extract to .odt and found this strange bug

When trying to convert a general column (or a single cell) to a Date, it adds this ’ which I can’t get rid with Find and Replace tool

In Only office, there don’t seem to add ', but the date doesn’t change either, but seems like LO should be able to find ’ and replace with blank/

What have done/tried:

  • Read Chapter 4 of 7.6 Calc Guide and tried the steps to change date automatically with no success
  • Libreoffice Help wasn’t helpful as “change data automatically” was about Headers/Footers, not chapter 4 info or a summary


MacOS: 14.2.1
LO: 7.6.4

See this FAQ article: Frequently asked questions - Calc - The Document Foundation Wiki

1 Like

Thank you, this is exactly what was looking for, these FAQ should be in LO Help (F1) for offline use

The consensus in technical documentation is that there should be several types of it, see for example this system: So our Help, guides, FAQ pages conform to this idea.